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Overview:  MS FrontPage is provides useful tools for creating, maintaining, and analyzing web sites.  In addition to 
a WYSIWYG (What You See Is What You Get) editing window, MS FrontPage has an HTML editing window with 
which we can edit the HTML code and insert JAVA or JavaScript code and a Preview window with which to view 
the web page as we create it.  MS FrontPage’s similarity to MS Word makes learning to use MS FrontPage 
relatively easy.  Our examination of MS FrontPage will include design considerations, the use of templates, adding 
content to pages, adding hyperlinks to pages within your website and hyperlinks to external sites, adding pictures 
and clipart, website navigation including the creation of navigation bars, and the use of tables to organize and to 
format both text and graphics. 
 
Starting MS FrontPage 2000:  When we start MS FrontPage, the FrontPage dialog box appears, Figure 1.  While 
we may initially choose to use MS FrontPage as a web page editor, we may want to use other programs to create 
and to edit web pages as well.  So, it is best not to set a particular program as a default web page editor.  Figure 2 
displays our first view of the program window. 
 

  
Figure 1  The FrontPage dialog box. Figure 2  The MS FrontPage window. 

 
Program Views:  When we open the program, we may find the Views Bar open as in Figure 3..  As we can see, we 
have the option to view the page alone as in Figure 2, the folders in our web (the folder containing our web page 
files), reports about our web, information about navigation of our site, and information about the hyperlinks to and 
from pages. 
 

  
Figure 3  The MS FrontPage window displaying Views 
Bar. 

Figure 4  The View 
menu. 
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If desired, we can turn off the Views Bar and change the program view displayed in the program window using the 
View menu, Figure 4.  When either the Views Bar or the Folder List is turned on, there is a check next to the Views 
Bar entry or the Folder List entry, respectively, on the View menu.  The Views Bar allows us to change the program 
view by left-clicking on any of the view icons displayed on the Views Bar or by left-clicking on the desired view on 
the View menu.  The Folder List allows us to examine and manipulate the contents of the web in which we are 
working, this includes creating, moving, renaming, and deleting both files and folders, in the same manner in which 
we use the Windows explorer.  While turning off the Views Bar and the Folder List provide more space for viewing 
the web page that we create, it can be very helpful to display the Folder List while editing and managing a web.  So 
in general, we will work in the program window with the Views Bar turned off and with the Folder List displayed. 
 

  
Figure 5  The MS FrontPage window with Views Bar 
and Folder List for an open web. 

Figure 6  The Hyperlinks view of the page 
extra_help/index.htm. 

 
The Hyperlinks view displays information about the hyperlinks to and from web pages.  In Figure 6, we see the 
Hyperlink View for the page extra_help/index.htm in the author’s web site.  We see that there are two hyperlinks to 
the page and four hyperlinks from the page.  The Hyperlinks View does not display information about hyperlinks 
created using a JavaScript with a pull down menu – this is the main method of navigation used in this web site. 
 
The Task entry on the Views Bar can be used as a sort of to-do list to schedule the development of the web. 
 

  
Figure 7  The Reports View of the author’s web site. Figure 8  The Toolbars popup 

menu for the View menu. 
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We use the Report View to obtain information about the hyperlinks, files, folders, and size of our web.  Figure 7 
displays the Report View for the author’s web site.  If we examine a web site using the Report View while work 
without a connection to the WWW, MS FrontPage cannot verify the external hyperlinks.  The report provides a 
variety of information about a web site that can be helpful for web site management. 
 
Customizing the MS FrontPage 2000 Program Window 
Customizing the program window is helpful if we use the program frequently.  Using the toolbars can save time, 
and customizing the program environment can make the program feel more user friendly (and similar to other 
programs) that we use.  To add toolbars and toolbar buttons, we select Customize on the Toolbars submenu of the 
View menu. 
 
Of the toolbars listed on the Toolbars submenu, we can display any toolbar that is not displayed or close any 
toolbar that is displayed by left-clicking on the toolbar name.  In Figure 8, we see that in this case, the Standard, 
Formatting, Navigation, Pictures, Style, and Tables toolbars are displayed.  The DHTML Effects, Positioning, and 
Reporting toolbars are not displayed. 
 
Left-clicking the Customize entry on the Toolbars submenu of the View menu, we generate the Customize dialog 
box.  We use the Toolbars tab, Figure 9, to turn on and off the toolbars just as we can using the Toolbars submenu 
of the View menu.  We use the Commands tab, Figure 10, to add and to remove toolbar buttons.  We use the 
Options tab, Figure 11, to change some of the toolbar display options. 
 

  
Figure 9  The Toolbars tab of the Customize dialog box. Figure 10  The Commands tab of the Customize dialog 

box. 
 
To add toolbar buttons to any of the toolbars displayed at the top of the program window, we select the category on 
the Commands tab and left-click the desired command and drag the toolbar button to the desired location among 
the displayed toolbar buttons.  If we need a description of the command corresponding to the selected toolbar 
button, we left-click the Description box.  To remove a toolbar button while customizing the toolbars, we left-click 
the toolbar button and drag it off the toolbar onto the editing window. 
 
We use the Toolbars tab, Figure 9, to restore the original toolbar buttons to a toolbar after we have added or 
removed toolbar buttons.  On the Toolbars tab, we select the toolbar that we would like to reset by left-clicking on 
the name of the toolbar, and then click the reset button. 
 
We use the Options tab to change how the toolbar buttons are displayed.  We uncheck the “Standard and 
Formatting toolbars share one row” option in order to allow the Standard toolbar and the formatting toolbar to be 
displayed as separate toolbars, and we uncheck the “Menus show recently used commands first” option so that the 
toolbar buttons will be displayed in the same position whenever we open the program.  When we have completed 
customizing the program environment, we left-click the Close box. 
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Figure 11  The Options tab of the Customize dialog box. Figure 12  The Open Web dialog box. 
 
We can also customize the program window by selecting Customize on the popup window generated by left-
clicking on any of the downward arrows at the end of the toolbars; we can use this popup menu to remove toolbar 
buttons as well. 
 

Opening A Web:  We can open the web in one of two ways, using the Open Web toolbar, , or by left-clicking 
Open Web entry on the File menu.   As previously mentioned, a web is a folder in which we save all the files of our 
web site.  For this handout, let us create a folder named My_FrontPage_Webstuff.  We can create this folder using 

the New Folder toolbar button, , in the Open Web dialog box, Figure 12, or using the Windows Explorer.  We 
must be careful not to use spaces in folder names and files names.  While Windows allows the use of spaces in file 
names and folder names, some servers do not allow the use of spaces.  For the servers that do allow spaces in 
folders and file names, the spaces are replaced by percent signs (%) and 20’s in the URL displayed in the web 
browser but entering the URL with percent signs (%) and 20’s in place of the spaces does not allow us to view the 
web page. 
 

  
Figure 13  The Add FrontPage Information to 
the Folder dialog box. 

Figure 14  The program window after we open our 
web. 
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Since this folder is new, the Add FrontPage Information to the Folder dialog box, Figure 13, appears on the screen.  
The program uses this dialog box to inquire about adding necessary folders and information to our web.  Since 



adding this information does not affect the contents of the folder, any folder can be a web.  We left-click the Yes 
box to allow the program to add the appropriate information to our web, My_FrontPage_Webstuff.  After we left-
click the Yes box, the program opens the Folder List to display the contents of our web and displays a new page so 
that we are ready to create web pages. 
 
Creating Web Pages:  When we opened the web, a new page was generated.  Any time we want to create a new 

web page, we can create the new page in one of three ways:  by left-clicking the New Page toolbar button, , 
by left-clicking the Page entry on the New submenu of the File menu, or by using the Control N key sequence. 
 
When we use select Page on the New submenu of the File menu, we open the New Page Wizard, Figure 15.  This 
page wizard allows us to access a variety of formatted and styled pages into which we can type the page 
information.  The formatting for these pages can be changed in the same way in which we can change the 
formatting for tables and cells that we can create on a blank page. 
 
If we want to select a blank, unformatted page, we select a Normal Page.  If we like one of the preformatted pages, 
we can select the page this page and make any desired formatting, font, color scheme changes as we enter the 
page information.  The New Page Wizard provides a preview of the formatted pages, Figure 16, that can be helpful 
in choosing a page. 
 

  
Figure 15  The New Page Wizard. Figure 16  The New Page wizard providing a preview of 

one of the formatted pages.  
 
The best thing to do is experiment:  play with the pages, blank and formatted, and decide what we like better.  
Since the formatted pages already contain the tables and the picture locations, we will use a blank page and 
experiment with it, entering tables, pictures, and text. 
 
To create a blank page for which we can choose the font, formatting, and color scheme, we left-click the Normal 
Page icon and left-click the Ok box. 
 
Page Views:  The program has three page views, the Normal view which is similar to the MS Word editing window, 
the HTML view, and the Preview View.  We can enter the page information using the Normal view just as we would 
if we were using MS Word; this is the WYSIWYG (What You See Is What You Get) editor.  Although this page 
appears blank in the Normal view of the editing window, we can view the html code that MS FrontPage generates 
at the beginning of the page when we left-click the HTML tab, Figure 17.  The header contains the program 
information.  When we begin entering information on the page, the HTML code will be placed between the HTML 
code that indicates the body of the page; the HTML code will be entered between <body> and <\body>.   
 
The HTML view can be helpful in learning HTML code since we can experiment with various tools and enter various 
page objects and use the HTML view to examine the HTML code that is generated.  In addition, the HTML view 
allows us to edit the HTML code generated by the program.  We can add code to change the formatting of the page 
as well as add, for example, JavaScript. 
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Figure 17  The HTML view of our blank page. Figure 18  The Tools menu. 

 
Setting The Program’s Default Font 
The initial default font for the program is set at Times New Roman.  If we want to change the default font to Arial, 
for example, we do this by selecting Page Options on the Tools menu, Figure 18.  This opens the Page Options 
 

 
Figure 19  The Default Font Tab in the Page Options 
dialog box. 

 
dialog box, and we set the default font for the program using the Default Font tab, Figure 19.  To select the desired 
font, Arial in this example, we left-click the down arrow for the Default proportional font pull-down menu and find 
Arial in the font list.  We left-click on Arial to select this font.  We change the Default fixed-width font in the same 
manner.  When we have set the default font, we left-click  the Ok box.  If we do not know any html code, it is best 
not to change any of the information displayed on the HTML Source tab and the Color Coding tabs. 
 
Text Styles:  In order to change the text style without knowing the HTML code, we must return to the Normal view; 
we click the Normal tab for the editing window. 
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Examining , the pull down menus for the Font Style, Font Type, 
and Font Size, respectively, we see that, currently, there is no Font Style selected, the default font will be used 
when we enter information in the editing window, and the Font Size is Normal.  We can change any of these by left-
clicking on the downward arrows and selecting the desired Font Style, Font Type, or Font Size on the pull down 
menu.  The best way in which to understand how the styles affect the text size is to test them and to compare the 
results. 
 

  
Figure 20  The various Font styles used for comparison. Figure 21  The rest of our Font style comparison. 
 
Examining the various Font styles, Figures 20 and 21, allows us to compare the size and readability of the styles.  
We see that Heading 1 is the largest of the heading styles, the font size for the various lists is similar, and that the 
Definition style alternates with the Defined Term style. 
 
However, this only displays how the styles appear in the editing window.  To view the styles as they appear on web 
pages, we must preview our page.  While we can do this using the Preview view, it is always best to preview the 
page in a web browser since this is a “live” web page preview.  In addition, we should preview any page that we 
plan to post on the World Wide Web using both Netscape Navigator and MS Internet Explorer. 
 

  
Figure 22  The program Preview view of our type style 
experiment. 

Figure 23  The rest of the program Preview view of our 
type style experiment. 

 
Previewing A Page in a Web Browser:  To preview the page using a browser, we left-click on the Preview in 

Browser toolbar button, , or select Preview in Browser on the File menu.  The only difference between these 
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options for previewing the web page in the browser is that the Preview in Browser option on the File menu, Figure 
24, opens the Preview in Browser dialog box, Figure 25, that allows us to choose the browser and screen size.   
 

  
Figure 24  The File 
menu. 

Figure 25  The Preview in Browser dialog box. 

 
Testing the font using both web browsers and different screen sizes allows us to consider the user.  Since the end 
user might have a small screen, checking the page for readability would be helpful and could make the difference 
between the page being readable or unusable.  The most important thing that we do while we create a web page is 
to consider those who will be reading and using our page.  If the page is hard to read, if the information is not easy 
to access, and if the page is slow to load then the page is neither useful nor helpful. 
 

 
Figure 26  The MS FrontPage dialog box that appears when we try 
to preview our type style experiment page in the web browser 
before we have saved the page. 

 
Before we can preview our page in the web browser, we must save the page.  If we have not saved the page, the 
program will open a dialog box inquiring if we want to save the page.  When we left-click the Yes box, the Save As 
dialog box appears on the screen.  We enter the name of our file, Type_Style.htm in the File name box and change 
the  Page title by left-clicking the Change box.  We enter the page title in the Set Page Title dialog box and left-click 
the Ok box. 
 
If we want to save the page in a new folder within our web we can create a new folder by left-clicking the New 

folder toolbar button, , and entering the name for the folder as previously discussed.  If we want to save the 
page in a different folder either in our web or in an different location on our hard drive or on a disk, we select the 
location using the Save in pull down menu and then left-click the Save box to save the file. 
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Figure 27  The Save As dialog box. Figure 28  The Set Page Title dialog box. 
 
Once we have saved the file, the web browser that we selected opens and we can view our new web page. 
 

  
Figure 29  The web page previewed in the web 
browser. 

Figure 30  The rest of our web page previewed in the 
web browser. 

 

If we had used the Preview in Browser toolbar button, , then MS FrontPage would open the last web browser 
that was used to view web pages.  If the Preview in Browser toolbar button is used the first time the program is 
used then MS FrontPage will open the default web browser. 
 
It is important to notice the title at the top of the browser window.  The browser displays the page title at the top of 
the browser window.  This title is used to identify the page in the browser as well as provide a name for the page in 
the browser bookmarks/favorites.  If we had not changed the page title then, by default, MS FrontPage would use 
part or all of the first line of text as the page title.   
 
Setting The Page Properties:  The Page Properties dialog box can be used to set, among other things, the page 
title, background sounds, page backgrounds, the color scheme for hyperlinks, the type, size, and style of the font, 
and the margins for the page.  To open the Page Properties dialog box, Figure 33, we select Properties on the File 
menu, Figure 31, or left-click on the Page Properties option on the popup menu that appears when we right click in 
the editing window, Figure 32.  Here, we left-click on Properties on the File menu. 
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Figure 31  The File 
menu. 

Figure 32  The right-click 
popup menu. 

 

  
Figure 33  The General tab of the Page Properties 
dialog box. 

Figure 34  The Modify Style dialog box. 

 
Using the General tab of the Page Properties dialog box, we can enter the page title, add background sound, and 
change the style of the page.  To change the page title, we enter the desired text in the Title box.   
 
We should be careful of using background sound files.  Using background sound files can make a web page and 
even the entire web site seem childish and unprofessional.  In addition, background sounds can be annoying to 
those who visit the web page.  Most important, background sound files increase the download time for a web page.  
Those trying to visit our web page, especially those using a modem, may choose to stop the download process if 
the page is slow to open in the web browser. 
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Figure 35  The Modify Style dialog box with Format pull 
down menu. 

Figure 36  The Font dialog box. 

 
Left-clicking the Style box opens the Modify Style dialog box, Figure 34.  We can change the Font, Paragraphs, 
Borders and Shading, Bullets and Numbering, and Positioning using the drop down menu that appears when we 
left-click the Format box, Figure 35.  Selecting an entry on the drop down menu opens the dialog box associated 
with each entry on the menu. 
 

  
Figure 37  The Paragraph dialog box. Figure 38  The Borders and Shading dialog box. 
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Figure 39  The Bullets and Numbering dialog box. Figure 40  The Position dialog box. 
 
Using the Font dialog box, Figure 36, we can set the font type, style, and size as well as the font effects and 
character spacing for the page.  As we browse the fonts, a sample is displayed in the Preview box at the bottom of 
the dialog box.  Since the standard format for hyperlinks is underlined text, we should be careful not to use 
underlining for general text. 
 

  
Figure 41  The Background tab of the Page Properties 
dialog box. 

Figure 42  The Margins tab of the Page Properties 
dialog box. 

 
We use the Paragraph entry on the Format drop down menu on the Modify Style dialog box to open the Paragraph 
dialog box, Figure 37.  Using this dialog box, we can change the alignment, indentation, and spacing for the page.  
Left-clicking the border entry of the Format drop down menu opens the Borders and Shading dialog box, Figure 38.  
We can use the tabs in this dialog box to add, change, and remove borders and shading for the page.  We can use 
the Preview windows on each tab to get a general idea of the effect of the changes that we make on our page. 
 
The Numbering entry on the Format drop down menu opens the Bullets and Numbering dialog box, Figure 39.  
Using this dialog box we can set up the bullet and numbering schemes to be used on the page.  Of course, we can 
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also use the Bullets and Numbering entry on the Format menu when we are editing the page.  Left-clicking on the 
Format drop down menu opens the Position dialog box, Format 40, in which we can change the wrapping style and 
the positioning style for the page. 
 

  
Figure 43  The Background tab of the Page Properties 
dialog box with background color pull down menu. 

Figure 44  The More Colors dialog box.. 

 
Using the Background tab of the Page Properties dialog box, Figure 41, we can set the background for the page, 
the text color, and the hyperlink colors.  The background can be a solid color, set using the Background Colors pull 
down menu displayed in Figure 43.  If we do not like the colors that are displayed on the pull down menu, we can 
left-click the More Colors entry to open the More Colors dialog box, Figure 44.  We can select one of the colors 
displayed on the palette or we can left-click the Custom box to open the Colors dialog box, Figure 45, in which we 
can move the slider to create custom colors.  We should be careful of creating custom colors because although 
these colors may look nice when we create the page, custom colors may not display in the same manner when the 
page is displayed in the visitor’s web browser since those visiting the page may not have the same display 
capabilities and settings that we have.  If we choose to use a background picture, we left-click in the check box and 
either enter the file name and location or we can left-click the Browse button to browse the computer for the file.  If 
we want to use the same background as another page in our web, we can left-click the Get background information 
from another page check box and either enter the page information or browse for the page.  Whenever we need to 
specify a file name or location, it is best to us the associated Browse box since it is important to use the correct file 
name and file location information. 
 

  
Figure 45  The Color dialog box. Figure 46  The new background color for our page. 
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We set the hyperlink colors in the same manner using the labeled pull down menus.  We should be careful to make 
sure that hyperlinks can be distinguished from text.  We should not rely on the cursor’s changing from an arrow to a 
hand with a pointed finger to indicate the presence of hyperlinks for those who display the page. 
 
In addition to background colors and background files, we could select to use a picture to create a Watermark for 
the page.  To do this we left-click the Background check box, left-click the Watermark check box, and specify the 
desired file. 
 
Using the Margins tab of the Page Properties dialog box, Figure 42, we can set the top margin and the left margin 
for our page.  We can include extra returns to create a margin at the bottom of the page.  Due to the various 
window sizes, it is impossible to specify a margin on the right-hand side of the screen. 
 
Since we have examined all the possibilities, let us leave the hyperlink color scheme as it is but let us change the 
background color to a pale yellow.  To do this, we left-click the down arrow for the Background color and left-click 
the More Colors option on the pull down menu.  Using the color palette, we can select a pale yellow and the left-
click on the Ok box.  When we have completed our Page Properties changes, we left-click the Ok box.  Our new 
background color is displayed in the page editing window, Figure 46.  Since we have completed our changes to the 
Page Properties, let us save our Type_Style.htm page.  If we want to save the page in a new folder or with a new 
file name then we would select the Save As entry on the File menu.  Since we want to save the file in the same 
location and using the same file name, we can use the Save entry on the File menu or the Save toolbar button, 

. 
 
Approximate Download Time:  MS FrontPage provides an estimate of the download time for the page using a 
28.8 modem.  The Estimated Time To Download information is displayed at the bottom right hand side of the MS 
FrontPage window to the right of the hourglass.  For our page, the estimated download time is 1 second using a 
28.8 modem.  If we add a background sound file, pictures and hyperlinks, the download time will increase as the file 
size increases. 
 
Selecting File Names For Pages:  As previously discussed, it is important not to use spaces in the names of files 
and folders in our web.  If we were to use spaces in file names or folder names, these spaces would be replaced 
with percent signs (%) and 20’s in the URL that is displayed in the web browser, and we would not be able to enter 
the URL in the web browser in order to view our web pages.  In addition, some servers will not accept files and 
folders with names that contain spaces.  If we want to use a space in a file name or folder name, we should use 
and underscore ( _ ).  We should be careful of using filenames that are too long since some servers have file name 
and folder name length restrictions.  Using codes or file names and folder names that are too short and that do not 
carry much information can make recognizing pages by file name and locations by folder name difficult.  The name 
of the file or folder is meaningless if we cannot remember what the file or the folder contains. 
 
Creating a Home Page:  Any page can act as the home page for a web site.  In general, the home page is the first 
page the user visits in a web site.  Let us create a new page to act as the home page for the web site that we are 
creating.  We will create some hyperlinks on our new home page to external web sites, some email hyperlinks, and 
a hyperlink from our home page to the page that we created, Type_Style.htm.   
 
Depending on the set up of the server on which we post our web site, we may need to name our home page 
differently.  For the Microsoft Internet Information Server [IIS], we might have to name our home page default.asp, 
and for the Netscape Suitespot Server, we would name our home page index.html; default.html is also a possibility.  
We must consult the server administrator to determine the appropriate name for our home page before we can post 
our site on the server.  For our example, we will use index.html. 
 
Now we create our homepage page.  We can leave our Type_Style.htm file open while we create the new page or 

we can close the page using Close in the File menu or the Close toolbar button, .  Let us leave this page open 
so that we can go back to it and add a hyperlink to our index page. 
 

Again, to create a new page, we can left-click the New Page toolbar button, , left-click the Page entry on the 
New submenu on the File menu, or use the Ctrl-N keyboard shortcut.   
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Let us use the Control-N key sequence to generate our new page.  Since this is the second page that we have 
created, the page name at the top of the editing window is new_page_2.htm.  We will change the name of the page 
to index.html when we save the page. 
 
Changing the Color, Size, and Type For The Font Of Selected Text:  Let us enter some text on our new page 
so that we can experiment with change the color, size and type of the font.  Suppose we type the author’s name 
and affiliation, and suppose we select two different fonts, Arial Rounded MT Bold font in Fuchsia for the author’s 
name and Bauhaus 93 font in teal for the affiliation.  After selecting (highlighting) the text, we can use the Font entry 
on the Format menu, Figure 49, the Font Type pull down menu, Figure 47, or Font entry on the right-click popup 
menu for highlighted text, Figure 50, to select the desired font types. 
 

    
Figure 47  The Font Type pull down 
menu. 

Figure 48  
The Font 
Size pull 
down 
menu 

Figure 49  The Format menu. Figure 50  The right-click 
popup menu for 
highlighted text. 

 
Using the Font Type pull down menu is the easiest way in which to change the font type.  The Font dialog, Figure 
53, box allows us to change all the font attributes at the same time.  So, we select the font type using the Font pull 
down menu on the Font tab and we use the Color pull down menu to select the font color in the same way in which 
we changed the background color of our Type_Style.htm page. 
 

 

 
Figure 51  The Font 
Color toolbar button 
pull down menu. 

Figure 52  The More Colors dialog box. 
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If we do not want to use the Font dialog box, we can use the Font Type pull down menu, Figure 47, and the Font 

Color toolbar button, , to change the color of the text.  So, to change the font type, we select (highlight) the 
text, left-click the downward arrow of the Font Type pull down menu, left-click on the font name after finding it in the 
menu using the slider on the side.  Then, with the text still selected (highlighted), we left-click the downward arrow 
on the Font Color toolbar button and either left-click on one of the displayed colors displayed on the pull down 
menu, Figure 51 or left-click on the More Colors entry on the menu to open the More Colors dialog box, Figure 52. 
 

  
Figure 53  The Font dialog box. Figure 54  The MS FrontPage window displaying the 

new font colors. 
 
Now that we have examined how to change the font type and the font color, let us explore the font size. 
 

  
Figure 55  The program window displaying the new 
text. 

Figure 56  The Save As dialog box. 

 
We can either enter all the text and then change the font size for selected text or change the font size as we enter 
the text.  The simplest way in which to do this is to change the font size as we enter the text.  So, we left-click the 
downward arrow to open the Font Size pull down menu, Figure 48, select the desired font size, and then enter the 
text.  Doing this for all the available font sizes, Figure 55, allows us to compare the font sizes.  Before we preview 
our new page in the web browser, we must save the page.   
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Saving the Page:  We can left-click the Save or the Save As entry on the File menu or left-click the Save toolbar 

button, .  Since we have not saved the file before, the Save As dialog box, Figure 56, opens.  We see that MS 
Font Page has used Dr. as the title for the page and as a potential file name.  We left-click the Change box to open 
the Set Page Title dialog box, Figure 57, enter the page title, This is our home page, for this example, and left-click 
the Ok box.  We enter the File name, index.html, in the file name box and left-click the Save box. 
 

  
Figure 57  The Set Page Title dialog box. Figure 58  The Save As dialog box with new page title 

and file name. 
 
Now that we have saved our page, we can preview the page in the web browser.  To do this we left-click the 

Preview in Browser entry on the File menu, Figure 31, or left-click the Preview in Browser toolbar button, .  
Examining the page preview in Figure 59, we see that 8 point text would be good for an extra navigation bar that 
appears at the bottom of a page but not good for ordinary text since it is rather small.  18 point, 24 point, and 36 
point text is rather large for ordinary text but it would be good for headings.  10 point text could appear small when 
displayed on some screen sizes, and 14 point text could appear too large when displayed on some screen size.  In 
general, 10 point, 12 point, and 14 point text is readable. 
 

  
Figure 59  The page preview of the index.html page  Figure 60  Entering a URL generates a hyperlink. 
 
Creating Hyperlinks:  Now let us add hyperlinks to our home page.  Just like for programs like MS Word, when we 
enter a URL on our page, the URL will automatically become a hyperlink.  Let us try that by entering the URL for 
ICTCM, http://www.ictcm.org.  Here we enter some text as well as the hyperlink to identify the hyperlink to the 
reader, Figure 60, “If we left-click on the URL http://www.ictcm.org then our web browser will open and the ICTCM 
home page will be displayed in the web browser”. 
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Now let us create a hyperlink from the text Framingham State College to the College’s home page.  First, we enter 
the desired text and select Framingham State College.  Next, we can left-click the Hyperlink entry on the Insert 
menu, Figure 61, left-click on the Hyperlink entry on the selected text right-click popup menu, Figure 50, left-click on 

the Hyperlink toolbar button, , or use the Ctrl-K keyboard shortcut to open the Create Hyperlink dialog box, 
Figure 62.  We can view the files and folders of our web in the main window of the Create Hyperlink dialog box.  
While we can use the  button to use the web browser to select the page or file, we can also enter the URL in the 
URL box.  Here, we will enter the URL http://www.framingham.edu and then either press Enter or left-click the Ok 
box.  Since we did not change the hyperlink color scheme for the page, we see that both of the hyperlinks that we 
created are in underlined blue text. 
 
 

  
Figure 61  The 
Insert menu. 

Figure 62  The Create Hyperlink dialog box. 

 
Now let us create a hyperlink to the Type_Style.htm page.  As before, we enter the desired text, “To view our type 
style experiment, click here”, select the word(s) that we would like to use for the hyperlink, in this case the word 
“here”, and open the Create Hyperlink dialog box.  Since we would like to create a hyperlink to a file in our web we 
can either left-click the desired page in the file and folder window on the dialog box or left-click the Create Hyperlink 

to File button, .  If we cannot find the desired file or folder displayed in the file and folder window then we must 

use the Create Hyperlink to File button, .  Here, let us use the Create Hyperlink to File button to open the Select 
File dialog box, Figure 63.  Using the Select File dialog box we can browser the computer’s hard drive for the file of 
interest.  In this case we must open our web My_FrontPage_Webstuff, Figure 64. 
 

  
Figure 63  The Select File dialog box. Figure 64  The contents of our web displayed in the 

Select File dialog box. 
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Once we have opened our web folder, we can enter the file name in the File name box, left-click on Type_Style and 
left-click the Ok box or double left-click on Type-Style in the dialog box window.  Now the word “here” is a hyperlink 
to our Type_Style.htm page. 
 
Finally, let us create an email hyperlink to the author.  Just like with URL’s, entering an email address creates an 
email hyperlink.  So, entering smabrouk@frc.mass.edu creates an email hyperlink on our page.  In addition, we can 
create a text mailto hyperlink.  As before, we enter the desired text, “To send email to Dr. Mabrouk, left-click here”, 
select the word(s) that we would like to use for the hyperlink, again, the word “here”, and open the Create Hyperlink 
dialog box.  To create a mailto hyperlink we can left-click the Create Email Hyperlink button, , to open the 
Create E-mail Hyperlink dialog box, Figure 65, enter the email address, and left-click the Ok box or enter “mailto:” 
followed by the email address in the URL box after removing the “http://”. 
 
Now let us go to our Type_Style.htm page and create a hyperlink to our index.html page.  We do this in the same 
way in which we created the hyperlink from our indext.html page to our Type_Style.htm page:  we enter the desired 
text on the page, “Left-Click here to go to home page”; we select the word(s) to which we would like to create the 

hyperlink; we open the Create Hyperlink dialog box; we left-click the Create Hyperlink to File button, , and select 
the file in the Select File dialog box; and left-click the Ok box to create the hyperlink. 
 

 
Figure 65  The Create E-mail Hyperlink dialog box. 

 
Once we have created the hyperlinks, it is important to test them.  So, we save the file and preview the page in the 
web browser to view and to test each of the hyperlinks. 
 

  
Figure 66  The Picture submenu of 
the Insert menu. 

Figure 67  The Clip Art Gallery. 

 
Adding Pictures And Clip Art:  Let us begin by adding some clip art to our home page.  To open the Clip Art 
Gallery, Figure 67, we can left-click the Clip Art entry on the Picture submenu of the Insert menu, Figure 66.  In the 
Clip Art Gallery, we can select one of the displayed topics or enter a word in the Search for clips box and press 
Enter.  Suppose we examine the Animal clips; to do this we left-click on the word “Animals” or the animals icon, 

.  We can move through the clips displayed, Figure 68, using the slider and left-click “Keep Looking” to search 
for more clips in this category, Figure 69.  once we have found a clip that we like, we can left-click, the clip icon or 
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right-click to display the clip menus, Figures 70 and 71.  On the left-click Clip Art Gallery menu, Figure 70, we use 
the first button to insert the clip, the second button to preview the clip, the third button to add the clip to the favorites 
category, and the fourth button to find similar clips.  To insert the clip on the page, we use the first entry of either 
menu. 
 

  
Figure 68  Various clips in the Animals category. Figure 69  More clips in the Animal category. 
 

  
Figure 70  The left-
click Clip Art Gallery 
menu. 

Figure 71  The right-click 
Clip Art Gallery menu. 

 

  
Figure 72  The selected clip inserted on the page. Figure 73  The resized clip. 
 
When we insert the clip, the image may be larger or smaller than we want it to be.  To resize the image, we left-
click on the image, move the cursor to one of the black squares at the corner of the image and drag diagonally until 
the image reaches the desired size.  Frequently, it is beneficial to resize in steps so that the image does not 
become distorted; if we resize from one of the squares on the top or side instead of from a corner then the image 
will become distorted. 
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In addition to using clip art, we can use pictures from files.  To insert a picture from a file, we choose the location to 
which we want to insert the picture, left-click the From File option on the Picture submenu on the Insert menu, 

Figure 66, or left-click on the Insert Picture toolbar button, , to open the Picture dialog box.  If the desired 

picture does not appear in the file and folder window, we left-click the Select File button, , and find the 
appropriate folder location and file using the Select File dialog box.  The desired picture, in this case the 
Framingham State College Seal, is inserted on the page when we left-click on the Ok box. 
 

  
Figure 74  The Picture dialog box. Figure 75  The Select File dialog box. 
 
We should include alternate text for any graphic images that we put on our web pages.  This alternate text will be 
used in place of the images for those who view the web page using text only web browsers and by those who turn 
off the graphics is their web browser.  In addition, the alternate text can be used to inform those viewing the page if 
we put a hyperlink on an image.  Let us add alternate text for each of our graphic images and add a hyperlink to the 
Framingham State College Seal to the College home page.   
 

  
Figure 76  The right-click 
popup menu for a selected 
picture. 

Figure 77  The Picture Properties dialog box. 
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First, let us add alternate text to our clip art.  We add alternate text, “This is a dog.”, in the Text box on the General 
tab of the Page Properties dialog box.  We use the Appearance tab to change the alignment, spacing, and border 
thickness of the picture.  When we have mad all the desired properties changes, we left-click the Ok box. 
 

  
Figure 78  The Edit Hyperlink dialog box. Figure 79  The Save Embedded Files dialog box. 
 
We add alternate text for a picture in the same manner.  In addition to adding the alternate text, let us add a 
hyperlink from the Framingham State College Seal to the College’s web site.  We open the Page Properties dialog 
box, enter the alternate text in the text box, and left-click the Browse box to open the Edit Hyperlink box, Figure 78, 
or enter the URL in the Location box.  We use the Edit hyperlink box in the same way in which we used the Create 
Hyperlink dialog box to create external hyperlinks, mailto hyperlinks, and hyperlinks to other pages in our web site. 
 
Before we preview our web page, let us add a motion clip from the Clip Art Gallery.  To add a motion clip, we open 
the Clip Art Gallery, left-click the Motion Clips tab, select a category and choose a clip.  The preview option on the 
left-click popup menu allows us to view the motion clip.  Like other graphics, we can add alternate text to motion 
clips; in this case, we use the alternate text “This is a running ram.” 
 

  
Figure 80  The new names and folder locations for the 
graphics embedded in our index.html page. 

Figure 81  The web preview of our index.html page. 

 
Saving our page, opens the Save Embedded Files dialog box, Figure 79.  Since the images have not been saved in 
our web before, the dialog box displays each image file name and the associated Action (Save, in this case).  We 
can rename the picture files so that they will be more meaningful to us in the future and either save them in the 
main web folder or specify a particular folder like the Images folder that MS FrontPage created within our web.  Let 
us rename each clip art file so that the file name is more meaningful (dog.gif for the dog and ram.gif for the running 
Website Creation Using MS FrontPage 2000  © Dr. Sarah L. Mabrouk, 2002 22 
 



ram), and let us save all the graphics in the Images folder.  To change the file names, we select the images one at 
a time, left-click the Rename box and enter the new file name, and left-click the Change Folder box to specify the 
location of the folder into which to save the images.  As we make the changes to the file names and specify the 
folder location, each image is displayed in the Picture preview window.  We left-click the Ok box when we have 
completed making the changes, Figure 80. 
 
Now we are ready to preview our home page in the web browser, Figure 81.  We see our running ram and, when 
we move the cursor over one of our graphic images, the alternate text appears on the screen in a text box.  When 
we preview the page using the Preview tab, Figure 82, we see the ram running and we can view the alternate text 
for our graphics. 
 

  
Figure 82  The Preview view of our index.html page. Figure 83  The Folder list displaying all the files in our 

web. 
 
Information About Our Web:  Left-clicking the plus (+) that appears next to the Images folder opens the folder to 
display the image files that we saved.  Using this folder view we can consider the structure of our web, create 
folders in which to save new pages and new images, and, in general, control the structure of our web site.  If we 
want to group images and pages by categories, using folders within the web can make it much easier to work on 
and update our web; using folders also make it easier to find pages and their associated embedded files. 
 

  
Figure 84  The Hyperlinks view of our index.html page. Figure 85  The Report view for our web site. 
 
Now that we have created our web site, we can examine the Hyperlinks view for our pages and create a Report for 
our web site.  If we generate a web site report when we do not have an Internet connection, we will see that our 
report records unverified hyperlinks. 
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Final Comments:  This concludes our introduction to web page creation using MS FrontPage 2000.  As we have 
seen MS FrontPage provides many helpful tools for web site creation, analysis, and maintenance. 
 
As with any software, the best way in which to master using the software is to experiment with the various aspects 
of the program and to use the help facility to get more information about the program.  Play with the MS FrontPage 
and have fun – this makes learning more enjoyable! 
 
As far as style goes, it is important to remember that to be useful, our web pages should be easy to read and easy 
to navigate, and the hyperlinks should be easy to find – remember to use alternate text with all graphics.   
 
As for colors, bright backgrounds with bright text can be difficult to read on the screen, and dark backgrounds with 
light text can be difficult to print and, in some cases, difficult to read.  Always be careful to think about the person 
who will be viewing the page and how the color selection may make the page difficult to read rather than thinking 
about the “cool color effects” created on the screen. 
 
Experiment, play, and have fun! 
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